_C.cpython-38-x86_64-linux-gnu.so: undefined symbol: _ZN6caffe28TypeMeta21_typeMetaDataInstanceIdEEPKNS_6detail12TypeMetaDataEv

We Are Going To Discuss About _C.cpython-38-x86_64-linux-gnu.so: undefined symbol: _ZN6caffe28TypeMeta21_typeMetaDataInstanceIdEEPKNS_6detail12TypeMetaDataEv. So lets Start this Python Article.

_C.cpython-38-x86_64-linux-gnu.so: undefined symbol: _ZN6caffe28TypeMeta21_typeMetaDataInstanceIdEEPKNS_6detail12TypeMetaDataEv

  1. How to solve _C.cpython-38-x86_64-linux-gnu.so: undefined symbol: _ZN6caffe28TypeMeta21_typeMetaDataInstanceIdEEPKNS_6detail12TypeMetaDataEv

    This error usually shows up when there's a compatibility issue between the installed pytorch version and the detector library version(Detectron2 or mmdet).
    Both the detector library and pytorch have to be built by the same CUDA version otherwise some packages will conflict when training your model.
    There's a possibility that the Pytorch (1.8.1) + CUDA version (11.1) you have is incompatible with detectron2 v(0.4).
    From the repo here, detectron2 v0.4 is built with torch 1.8 + cuda 11.1. It might help if you use torch 1.8.0 instead of 1.8.1

  2. _C.cpython-38-x86_64-linux-gnu.so: undefined symbol: _ZN6caffe28TypeMeta21_typeMetaDataInstanceIdEEPKNS_6detail12TypeMetaDataEv

    This error usually shows up when there's a compatibility issue between the installed pytorch version and the detector library version(Detectron2 or mmdet).
    Both the detector library and pytorch have to be built by the same CUDA version otherwise some packages will conflict when training your model.
    There's a possibility that the Pytorch (1.8.1) + CUDA version (11.1) you have is incompatible with detectron2 v(0.4).
    From the repo here, detectron2 v0.4 is built with torch 1.8 + cuda 11.1. It might help if you use torch 1.8.0 instead of 1.8.1

Solution 1

This error usually shows up when there’s a compatibility issue between the installed pytorch version and the detector library version(Detectron2 or mmdet).

Both the detector library and pytorch have to be built by the same CUDA version otherwise some packages will conflict when training your model.

There’s a possibility that the Pytorch (1.8.1) + CUDA version (11.1) you have is incompatible with detectron2 v(0.4).

From the repo here, detectron2 v0.4 is built with torch 1.8 + cuda 11.1. It might help if you use torch 1.8.0 instead of 1.8.1

Original Author Ellon Of This Content

Solution 2

well, i got the problem too. and i fixed it. it means that the static library /home/mona/research/code/frankmocap/detectors/hand_object_detector/lib/model/_C.cpython-38-x86_64-linux-gnu.so is not appropriate to this program. i guess you reinstalled something such as torch or detectron2.

to fix this problem, try to reinstall detectron2 and remove the detectors directory in frankmocap, then use ./scripts/install_frankmocap.sh ./scripts/install_hand_detectors.sh and ./scripts/install_pose2d.sh to reconstruct libraries which needed by frankmocap.

after all, maybe you need copy the _C.cpython-38-x86_64-linux-gnu.so from detectors/hand_object_detector/lib/build/lib.linux-x86_64-3.6/model to detectors/hand_object_detector/lib/model. maybe not

Original Author Fei Peng Of This Content

Solution 3

I tried the solutions mentioned here, but that didn’t fully solve the problem. However, when I tried solving a different error using this solution, it also solved this error for me. Use the following command:

pip install torch==1.8.0+cu111 torchvision==0.9.0+cu111 torchaudio==0.8.0 -f https://download.pytorch.org/whl/torch_stable.html

Original Author Charudatta Manwatkar Of This Content

Conclusion

So This is all About This Tutorial. Hope This Tutorial Helped You. Thank You.

Also Read,

ittutorial team

I am an Information Technology Engineer. I have Completed my MCA And I have 4 Year Plus Experience, I am a web developer with knowledge of multiple back-end platforms Like PHP, Node.js, Python and frontend JavaScript frameworks Like Angular, React, and Vue.

Leave a Comment