Because app requires SDK version >=2.15.1 <3.0.0, version solving failed

We Are Going To Discuss About Because app requires SDK version >=2.15.1 <3.0.0, version solving failed. So lets Start this Flutter Article.

=2.15.1-Because app requires SDK version >=2.15.1 <3.0.0, version solving failed

How to solve Because app requires SDK version >=2.15.1 <3.0.0, version solving failed

You should not update the dart version of this project, please open pubspec.yaml file and update
environment:
sdk: “>=2.12.0 <3.0.0”
to
environment:
sdk: “>=2.16.0 <3.0.0”

Because app requires SDK version >=2.15.1 <3.0.0, version solving failed

You should not update the dart version of this project, please open pubspec.yaml file and update
environment:
sdk: “>=2.12.0 <3.0.0”
to
environment:
sdk: “>=2.16.0 <3.0.0”

Solution 1

You should not update the dart version of this project, please open pubspec.yaml file and update

environment:
sdk: “>=2.12.0 <3.0.0”

to

environment:
sdk: “>=2.16.0 <3.0.0”

Original Author Qasim Of This Content

Solution 2

I think you should update dart version, can upgrade dart version this link

Original Author Yasin Ege Of This Content

Solution 3

like @Yasin Ege says, dart need to upgrade in order to use:

flutter channel <channel to update master or beta>
flutter upgrade

Original Author bebetor Of This Content

Solution 4

Run flutter upgrade, after run flutter pub get

Original Author ncutixavier Of This Content

Conclusion

So This is all About This Tutorial. Hope This Tutorial Helped You. Thank You.

Also Read,

ittutorial team

I am an Information Technology Engineer. I have Completed my MCA And I have 4 Year Plus Experience, I am a web developer with knowledge of multiple back-end platforms Like PHP, Node.js, Python and frontend JavaScript frameworks Like Angular, React, and Vue.

Leave a Comment