Cannot update spyder=5.1.5 on new anaconda install

We Are Going To Discuss About Cannot update spyder=5.1.5 on new anaconda install. So lets Start this Python Article.

Cannot update spyder=5.1.5 on new anaconda install

  1. How to solve Cannot update spyder=5.1.5 on new anaconda install

    (Spyder maintainer here) Our regular instructions to update Spyder don't work in this case because there are some incompatible dependencies between Spyder 5.0.5 and 5.1.5.
    To workaround this problem, you need to close Spyder and run the following commands in the Anaconda Prompt (or your system terminal on Linux or macOS):
    conda remove spyder conda remove python-language-server conda update anaconda conda install spyder=5.1.5
    The second or third commands (i.e. conda remove python-language-server or conda update anaconda) could give you errors, but that's fine. Simply ignore them and continue with the other commands.

  2. Cannot update spyder=5.1.5 on new anaconda install

    (Spyder maintainer here) Our regular instructions to update Spyder don't work in this case because there are some incompatible dependencies between Spyder 5.0.5 and 5.1.5.
    To workaround this problem, you need to close Spyder and run the following commands in the Anaconda Prompt (or your system terminal on Linux or macOS):
    conda remove spyder conda remove python-language-server conda update anaconda conda install spyder=5.1.5
    The second or third commands (i.e. conda remove python-language-server or conda update anaconda) could give you errors, but that's fine. Simply ignore them and continue with the other commands.

Solution 1

(Spyder maintainer here) Our regular instructions to update Spyder don’t work in this case because there are some incompatible dependencies between Spyder 5.0.5 and 5.1.5.

To workaround this problem, you need to close Spyder and run the following commands in the Anaconda Prompt (or your system terminal on Linux or macOS):

conda remove spyder
conda remove python-language-server
conda update anaconda
conda install spyder=5.1.5

The second or third commands (i.e. conda remove python-language-server or conda update anaconda) could give you errors, but that’s fine. Simply ignore them and continue with the other commands.

Original Author Carlos Cordoba Of This Content

Solution 2

I used $ conda install -c conda-forge/label/beta spyder
from here https://anaconda.org/conda-forge/spyder and got version 5.0.07a installed.

Original Author soirbleu Of This Content

Conclusion

So This is all About This Tutorial. Hope This Tutorial Helped You. Thank You.

Also Read,

ittutorial team

I am an Information Technology Engineer. I have Completed my MCA And I have 4 Year Plus Experience, I am a web developer with knowledge of multiple back-end platforms Like PHP, Node.js, Python and frontend JavaScript frameworks Like Angular, React, and Vue.

Leave a Comment