Create React App with an older version of node

We Are Going To Discuss About Create React App with an older version of node. So lets Start this Javascript Article.

Create React App with an older version of node

How to solve Create React App with an older version of node

I managed to run it. It seems like the last versions of the packages which support Node 8.x.x are 3.4.1 for create-react-app and 3.1.1 for react-scripts. What I did:
npm uninstall -g create-react-app npm install -g [email protected] create-react-app my-app --scripts-version 3.1.1
But it’s better to update your Node version to the actual (or LTS at least).

Create React App with an older version of node

I managed to run it. It seems like the last versions of the packages which support Node 8.x.x are 3.4.1 for create-react-app and 3.1.1 for react-scripts. What I did:
npm uninstall -g create-react-app npm install -g [email protected] create-react-app my-app --scripts-version 3.1.1
But it’s better to update your Node version to the actual (or LTS at least).

Solution 1

I managed to run it. It seems like the last versions of the packages which support Node 8.x.x are 3.4.1 for create-react-app and 3.1.1 for react-scripts. What I did:

npm uninstall -g create-react-app
npm install -g [email protected]
create-react-app my-app --scripts-version 3.1.1

But it’s better to update your Node version to the actual (or LTS at least).

Original Author sergdenisov Of This Content

Solution 2

From my understanding you can add the flag --scripts-version to your npx create-react-app command. So for example if you wanted to run react version 15.6 you would run something like:

npx create-react-app appname --scripts-version 1.0.14

You can reference the react-script repo as well as the NPM Package for more information on which version of the script you would want to run. Hopefully this helped! If not please let me know and I’m more than willing to try and look more into it.

Edit:

Forgot to mention that you need to make sure to change the versions of react and react dom within your package.json after. So after installing you would run:

npm i [email protected]
npm i [email protected]

Original Author wolfy Of This Content

Conclusion

So This is all About This Tutorial. Hope This Tutorial Helped You. Thank You.

Also Read,

ittutorial team

I am an Information Technology Engineer. I have Completed my MCA And I have 4 Year Plus Experience, I am a web developer with knowledge of multiple back-end platforms Like PHP, Node.js, Python and frontend JavaScript frameworks Like Angular, React, and Vue.

Leave a Comment