Flutter app running on web failing with error:

We Are Going To Discuss About Flutter app running on web failing with error:. So lets Start this Flutter Article.

Flutter app running on web failing with error:

How to solve Flutter app running on web failing with error:

I found a solution for this.
I added it to my pubspeck.yaml:
dependency_overrides: firebase_messaging_platform_interface: 3.1.6
Have a good day 🙂

Flutter app running on web failing with error:

I found a solution for this.
I added it to my pubspeck.yaml:
dependency_overrides: firebase_messaging_platform_interface: 3.1.6
Have a good day 🙂

Solution 1

I found a solution for this.

I added it to my pubspeck.yaml:

dependency_overrides:
  firebase_messaging_platform_interface: 3.1.6

Have a good day 🙂

Original Author Sonu Saini Of This Content

Solution 2

There were changes made to the dependencies of the Flutter Firebase packages
https://github.com/FirebaseExtended/flutterfire/pull/8156

You can either update to use 2.16.0 version of dart or newer.
Or override the dependencies, you only need to add the ones that you are using

dependency_overrides:
  firebase_messaging_platform_interface: 3.1.6
  firebase_storage_platform_interface: 4.0.14
  cloud_functions_platform_interface: 5.0.21
  cloud_firestore_platform_interface: 5.4.13
  firebase_auth_platform_interface: 6.1.11
  firebase_database_platform_interface: 0.2.0+5

Original Author Garrett Barlocker Of This Content

Solution 3

I have faced the same problem and got a workaround for this.

override firebase_messaging_platform_interface in pubspeck.yaml:

dependency_overrides:
  firebase_messaging_platform_interface: 3.1.6

check ref: https://github.com/FirebaseExtended/flutterfire/issues/8181

Original Author Sultan Mahmud Of This Content

Solution 4

As pointed out earlier by GarrettBarlocker, dependency overrides of all the firebase dependencies used in my project did the trick for me and it solved the problem.

Don’t try flutter upgrade as it upgrades your project to the latest version of the flutter release. And it will force you to migrate your project to android v2 embedding as v1 embedding is deprecated in flutter 2.10.2 thereby failing to compile and build the application. Also, you may face compatibility issues with other dependencies.

Original Author loke Of This Content

Conclusion

So This is all About This Tutorial. Hope This Tutorial Helped You. Thank You.

Also Read,

ittutorial team

I am an Information Technology Engineer. I have Completed my MCA And I have 4 Year Plus Experience, I am a web developer with knowledge of multiple back-end platforms Like PHP, Node.js, Python and frontend JavaScript frameworks Like Angular, React, and Vue.

Leave a Comment