Flutter Error: No named parameter with the name ‘displayLarge’

We Are Going To Discuss About Flutter Error: No named parameter with the name ‘displayLarge’. So lets Start this Flutter Article.

Flutter Error: No named parameter with the name ‘displayLarge’

How to solve Flutter Error: No named parameter with the name ‘displayLarge’

google_fonts: ^2.3.1 has also solved the problems left in google_fonts: 2.3.0
Well! This issue will be raised in all projects using the google_fonts with a caret sign (^).
The caret sign (^) is used for pub dependencies in Dart to indicate a range of version numbers that are allowed. Specifically, any version from the specified version up to (but not including) the next non-breaking version is ok.
So google_fonts: ^2.2.0 is the same as ‘>=2.2.0 <3.0.0’, It’s shorthand for the longer form. The ^ is saying, I want to automatically use the most up-to-date package from Pub as long as that update won’t break anything in my app. The google_fonts: 2.3.0 has some issues with this as of now.
Solution Steps :
Remove (^) from your current google_fonts. max can be set as google_fonts: 2.2.0.
To make sure, this does not conflict with any other dependency, for once do ‘pub get’.
Try to invalidate caches and restart. This should clean error, else do flutter clean to remove old updated google_fonts and pub get.
Done! You are good to go. Happy Codding!!!

Flutter Error: No named parameter with the name ‘displayLarge’

google_fonts: ^2.3.1 has also solved the problems left in google_fonts: 2.3.0
Well! This issue will be raised in all projects using the google_fonts with a caret sign (^).
The caret sign (^) is used for pub dependencies in Dart to indicate a range of version numbers that are allowed. Specifically, any version from the specified version up to (but not including) the next non-breaking version is ok.
So google_fonts: ^2.2.0 is the same as ‘>=2.2.0 <3.0.0’, It’s shorthand for the longer form. The ^ is saying, I want to automatically use the most up-to-date package from Pub as long as that update won’t break anything in my app. The google_fonts: 2.3.0 has some issues with this as of now.
Solution Steps :
Remove (^) from your current google_fonts. max can be set as google_fonts: 2.2.0.
To make sure, this does not conflict with any other dependency, for once do ‘pub get’.
Try to invalidate caches and restart. This should clean error, else do flutter clean to remove old updated google_fonts and pub get.
Done! You are good to go. Happy Codding!!!

Solution 1

google_fonts: ^2.3.1 has also solved the problems left in google_fonts: 2.3.0

Well! This issue will be raised in all projects using the google_fonts with a caret sign (^).

The caret sign (^) is used for pub dependencies in Dart to indicate a range of version numbers that are allowed. Specifically, any version from the specified version up to (but not including) the next non-breaking version is ok.

So google_fonts: ^2.2.0 is the same as ‘>=2.2.0 <3.0.0’, It’s shorthand for the longer form. The ^ is saying, I want to automatically use the most up-to-date package from Pub as long as that update won’t break anything in my app. The google_fonts: 2.3.0 has some issues with this as of now.

Solution Steps :

  1. Remove (^) from your current google_fonts. max can be set as google_fonts: 2.2.0.
  2. To make sure, this does not conflict with any other dependency, for once do ‘pub get’.
  3. Try to invalidate caches and restart. This should clean error, else do flutter clean to remove old updated google_fonts and pub get.

Done! You are good to go. Happy Codding!!!

Original Author ViKi Vyas Of This Content

Solution 2

Well, i don’t know if you have tried this, but this problem is described here: issue219

In summary you have to use google_fonts v2.3 for Flutter v2.1 or grater.

Original Author Firus Of This Content

Solution 3

Please follow the below steps to solve the issue.

  1. Open pubspec.yaml file.
  2. Change google_fonts: ^2.2.0 to google_fonts: 2.2.0
  3. Save.

Original Author ruwanmadhusanka Of This Content

Solution 4

set the package version to google_fonts: 2.2.0 and it should work properly

Original Author Mr.A2 Of This Content

Conclusion

So This is all About This Tutorial. Hope This Tutorial Helped You. Thank You.

Also Read,

ittutorial team

I am an Information Technology Engineer. I have Completed my MCA And I have 4 Year Plus Experience, I am a web developer with knowledge of multiple back-end platforms Like PHP, Node.js, Python and frontend JavaScript frameworks Like Angular, React, and Vue.

Leave a Comment