How can I fix “unsupported class file major version 60” in IntelliJ IDEA?

We Are Going To Discuss About How can I fix “unsupported class file major version 60” in IntelliJ IDEA?. So lets Start this Java Article.

How can I fix “unsupported class file major version 60” in IntelliJ IDEA?

Advertisements
  1. How can I fix “unsupported class file major version 60” in IntelliJ IDEA?

    In the file under the directory gradle/wrapper/gradle-wrapper.properties, just change the version number of Gradle.

  2. unsupported class file major version 60

    In the file under the directory gradle/wrapper/gradle-wrapper.properties, just change the version number of Gradle.

Solution 1

Advertisements

I fixed this problem by changing the Gradle JVM settings in IntelliJ settings:

  • In the Settings/Preferences dialog, go to Build, Execution, DeploymentBuild ToolsGradle.

  • Under the Gradle section, change the Gradle JVM option. Select a Gradle JVM which works for you.

    Enter image description here

See Resolve the Gradle JVM version for the existing project

Original Author Yu Jinyan Of This Content

Solution 2

Advertisements

For me, it was fixed by upgrading the Gradle version.

In the file under the directory gradle/wrapper/gradle-wrapper.properties, just change the version number of Gradle. For example, if your Gradle version is 6.3, change this:

distributionUrl=https\://services.gradle.org/distributions/gradle-6.3-bin.zip

to:

distributionUrl=https\://services.gradle.org/distributions/gradle-7.0-bin.zip

It is not available in FileProject StructureProject for the project I was working with.

Original Author John Lehmann Of This Content

Solution 3

Advertisements

Upgrading Gradle version 6.8.3 to 7.0 solved my problem. You can upgrade it:

  • Menu FileProject StructureProject (on the left panel)
  • Change to Gradle version 7.0

It works with the Android Gradle plugin version 4.2.0.

Original Author Emirhan Soylu Of This Content

Solution 4

Advertisements

For me, (in Flutter) the problem was that I was using Java JDK version 16, but version 16 is not supported for some packages.

So, I downgraded to JDK version 15.

On Windows, I did the following:

  1. Close your current IDE / Terminal (do not skip this step).

  2. Uninstall the current Java JDK and restart your computer.

  3. Download and install Java JDK version 15 from here (you are required to create an account in order to download).

  4. Update the JAVA_HOME Environment Variable.

Original Author MendelG Of This Content

Conclusion

So This is all About This Tutorial. Hope This Tutorial Helped You. Thank You.

Also Read,

Siddharth

I am an Information Technology Engineer. I have Completed my MCA And I have 4 Year Plus Experience, I am a web developer with knowledge of multiple back-end platforms Like PHP, Node.js, Python and frontend JavaScript frameworks Like Angular, React, and Vue.

Leave a Comment