Numba needs NumPy 1.20 or less for shapley import

We Are Going To Discuss About Numba needs NumPy 1.20 or less for shapley import. So lets Start this Python Article.

Numba needs NumPy 1.20 or less for shapley import

  1. How to solve Numba needs NumPy 1.20 or less for shapley import

    I use Numpy==1.21.4 and Numba==0.53.0, it works:
    pip install numba==0.53

  2. Numba needs NumPy 1.20 or less for shapley import

    I use Numpy==1.21.4 and Numba==0.53.0, it works:
    pip install numba==0.53

Solution 1

I use Numpy==1.21.4 and Numba==0.53.0, it works:

pip install numba==0.53

Original Author ah bon Of This Content

Solution 2

I believe the numba’s dependency with numpy 1.22 have been resolved in the most recent version. Try upgrading numba (works for me with numpy 1.22):

 pip install numba --upgrade

Original Author David Juraj Of This Content

Solution 3

I used pip install shap instead of conda install -c conda-forge shap and it worked for me.

Original Author 8Simon8 Of This Content

Solution 4

I ran into the same issue. the solution is to install numpy 1.18.1 with numpa 0.48.0 and it should work

Original Author Manaf Sheyyab Of This Content

Conclusion

So This is all About This Tutorial. Hope This Tutorial Helped You. Thank You.

Also Read,

ittutorial team

I am an Information Technology Engineer. I have Completed my MCA And I have 4 Year Plus Experience, I am a web developer with knowledge of multiple back-end platforms Like PHP, Node.js, Python and frontend JavaScript frameworks Like Angular, React, and Vue.

Leave a Comment